Christmas lights on Waterloo Road

Join in these discussions today! Log in or register.
Wednesday 28 November 2012 4.38pm
I love a good Christmas tradition, and we've got a new one round here. Every year the star decorations go up on the lamp posts in Waterloo Road, and every year none of them south of The Fire Station (or thereabouts) actually work. You'd think, wouldn't you, that someone would actually test them? (No. Silly me.) I wonder if it's a Lambeth/Southwark border dispute?
Wednesday 28 November 2012 10.48pm
There's one down The Cut not working either. It hasn't worked since they installed it and they just continued working their way up the street installing the others. Not sure who to report then to - any ideas anyone?
Thursday 29 November 2012 10.38am
The Waterloo Quarter BID is now aware of this thread - I'm sure they'll look into it.

Editor of the London SE1 website.
Subscribe to our SE1 Direct weekly newsletter.
Friday 30 November 2012 8.01pm
Thank you James!
Tuesday 18 December 2012 8.16pm
Light on The Cut still not working, perhaps the Waterloo Quarter Bid didn't see the post.
Wednesday 19 December 2012 8.17am
Yes, it bugs me whenever I go past. Someone please fix it!
Wednesday 19 December 2012 3.16pm
It's all fixed now and it looks lovely!!! Thank you one and all.
Wednesday 19 December 2012 3.25pm
Almost ditto on Blackfriars Rd - lovely twinkly star lights installed all the way down from the river to Webber Street; but no further. Not that they are just not working, they haven't even been installed.

Why? Is it a hinterland where there be dragons...
Wednesday 19 December 2012 10.54pm
The ones on Waterloo Road might be fixed, but the one on The Cut is still out.

To post a message, please log in or register..

Keep up with SE1 news

We have three email newsletters for you to choose from: